Keynua Status
Subscribe
to updates
Reniec Service down
Major incident
External services
Reniec
2021-09-17 16:45 UTC
· 3 hours, 6 minutes
Updates
Resolved
Connection established successfully
November 4, 2021 · 15:25 UTC
Issue
We are not able to establish a connection with Reniec service
November 4, 2021 · 15:25 UTC
← Back